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1. INTRODUCTION 

3D-Blast is a computer program that provides quick calculation and visualization of the effects of 
an open-air explosion on a variety of building shapes. Given the dimensions of the building and 
the size and location of an explosive charge, the program will estimate the pressure and impulse 
distribution on the building and map them as contours on a 3D representation of the structure. 
After an analysis is complete, the program contains an automated report writer, which can 
prepare a concise technical report highlighting the results. 

3D-Blast uses a special purpose software program that estimates the path the shock wave will 
follow from an explosion to a grid of points on the building. The range to each of these nodes on 
the 3D model is determined using the shortest path around the exterior of the facility. The 
software then uses an airblast driver to determine the appropriate pressure and impulse 
magnitudes for the range and orientation of each element. A non-cased, hemispherical 
detonation is assumed. The airblast equations documented in the U.S. Department of Energy’s 
“A Manual for the Prediction of Blast and Fragment Loading on Structures”, DOE/TIC 11268 
(1992) is the basis for the loading algorithms. 

The program provides a simple, quick approximation of the 3D engulfment of a structure. A 
significant feature of this program is the ability to manipulate the building dimensions and 
explosive location by clicking and dragging the building dimensions or target with the computer 
mouse. Once the 3D model is built, the user may rotate the structure, zoom in for detail and 
zoom out for perspective. These features allow the user to approximate parameters and quickly 
experiment with various options while visualizing their effects on the structure. The program 
currently contains nine building footprints for analysis: a Box, an L-Shape, a T-Shape, an S-Shape, 
a Z-Shape, a U-Shape, an O-Shape, an E-Shape, and an H-Shape. 

3D-Blast provides two different forms of output: 

• Full color 3D engulfment models 

• A report detailing the technical parameters and results including 3D engulfment models 

This User Guide contains an index of Toolbar Features and provides guidance for screen input. 
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2. PROGRAM OVERVIEW 

The main program screen of 3D Blast is divided into several functional elements.  The major 

program elements include the Program Menus, the Main Toolbar, the Model Control Area, 2D 

Building Footprint, and the 3D Model Screen as illustrated in Figure 2.1. 

 

Figure 2.1.  Opening screen for 3D Blast 3.5. 
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2.1. PROGRAM MENUS 

 Three Program Menus are available: the File Menu, the View Menu, and the Help Menu. 

The File Menu has standard windows file operations (New, Open, 
Save, Save As, Exit), as well as an option to write a 3D Blast Report.   

 

 

 

 

 

 

 

The View Menu provides an option to view the 3D 
model output in a separate window. 

 

 The Help Menu provides access to this User Guide, Import 
License, Generate License Request, the Release Notes, Software 
License Information, and the About Screen. 
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2.2. MAIN TOOLBAR 

 

The Main Toolbar provides an alternative method to accomplish most items in the Program 

Menus.  The program utilizes a variety of icons to simplify common tasks and allow quick access 

to the various libraries. 

New File 

Click this icon to start a “new” project.  

 

Open File  

 Click this icon to open previously saved files.   

 

Save File 

 Click this icon to save your file. 

 

Display Units 

 

This drop-down box allows the user to select which unit system to use. 

Run Analysis 

 Click this icon to run the analysis for the current set of inputs. 

 

3D View 

 Click this icon to view the 3D model results in a separate stand-alone window. 
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2.3. 2D FOOTPRINT TOOLBAR AND AREA 

 
 
Typically, the user starts by selecting a building footprint from the 2D footprint toolbar.  Select 
one of the nine shapes on the 2D Toolbar and the program will plot the building footprint selected 
on the upper portion of the screen.  For more complex shapes, footprints consist of a series of 
rectangles.  The user may change the dimensions by changing the line segments on the x and y-
axis.  The building footprint may be resized by clicking and dragging endpoints of the segment to 
the correct size or by entering the correct dimensions in the table under Geometry in the Model 
Control Area.  After making changes, the model will need to be run to update any output results. 
 

 
The Box, L-Shape, and T-Shape Building Footprints 
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S-Shape, Z-Shape, and U-Shape Building Footprints 

 
O-Shape, E-Shape, and H-Shape Building Footprints 
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2.4. MODEL CONTROL AREA 

The Model Control Area allows the user to define model parameters for the building Geometry, 

the explosive Charge, 3D Properties for the 3-dimensional view of the analyzed building model, 

and settings for generating a Report.  All units in this area will be based on the user selection in 

the main toolbar.  Changing this selection will change the display units and convert all values to 

the corresponding unit system. 

2.4.1. GEOMETRY 

Setting Dimensions in Geometry 

In this section, enter specific dimensions for length, width and height in the dx, dy and dz fields.  

More complex shapes consist of a series of rectangles where the user must define segments on 

the x and y-axes.  For these shapes, additional X and Y fields will be available for entering 

dimensions.  After entering dimensions, press enter or Tab on the computer keyboard to redraw 

the 2D building footprint.  Dimensions may also be changed by clicking and dragging an endpoint 

of the x or y-axis segment next to the footprint.  As you drag an endpoint, the values for the X or 

Y-axis will be updated. 

Number of Elements and Footprint Scale 

Each footprint is divided into elements along the X, Y and Z-axes.  When you Run the Analysis and 

transform the footprint into a 3D Model, the number of elements will be displayed on the model.  

More elements result in a finer mesh and higher resolution. 

The Footprint Scale defines the maximum and minimum values on the footprint display axes for 

the 2D Footprint Area. If the building has large dimensions, the scale must have large X and Y 

values.  Autoscale provides the scale that best displays the building shape in the viewing area. 

2.4.2. CHARGE 

Charge Location 

The charge is the explosive device, which is positioned around the building.  The coordinates can 

be entered in the input boxes or can be approximated by clicking and dragging the red circle 

(explosive charge) around the footprint.  If you enter new dimensions and drag the explosive 

charge (red circle) to a new location around the building footprint, the 2D Footprint View updates 

automatically. 
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Charge Size (Weight and TNT Equivalency) 

Specify the appropriate charge weight.  By default, the program assumes the explosive charge is 

TNT equivalent.  If an alternate explosive material is needed, click on the TNT Eq. field to bring 

the up Charge Weight Details form, shown below.  Available charge types include TNT, ANFO, C4, 

or User Defined.  If ANFO or C4 is selected, the program converts them into equivalent pounds 

of TNT based on either pressure or impulse equivalency (as specified by the user).  Alternatively, 

a user-defined explosive may be selected and the user must then define the TNT equivalency 

factor.   

  
 

A TNT equivalency factor of 0.5 would mean the charge would be half as energetic as the same 

weight of TNT explosive.  A factor of 2.0 would mean the charge would be twice as energetic as 

the same weight of TNT.  ANFO is 82% as energetic as TNT in terms of both pressure and impulse.  

C4 is 1.37 times more energetic than TNT when comparing pressure and 1.19 times more 

energetic when comparing impulse.  That means the peak blast pressure of 100 pounds or 

kilograms of C4 would be the same as that produced by 137 pounds or kilograms of TNT at the 

same standoff distance.  The peak impulse of 100 pounds or kilograms of C4 would be the same 

as that produced by 119 pounds of TNT. 

2.4.3. 3D PROPERTIES 

After defining the building footprint, dimensions, and charge properties, the model can be run 

by clicking the run analysis button in the Main Toolbar, the 3D View Toolbar, or by pressing the 

F5 key. After running the analysis, the 3D model will be displayed in the 3D model view and the 

3D Properties can be adjusted to determine what data will be displayed on the model as well as 

the range of values to display. 
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Scalar Variable 

Select one of four analysis options for viewing the blast effects on the 3D model.  The four options 

are Pressure (peak positive phase blast pressure from the charge), Impulse (positive phase 

impulse from the charge), Range (distance to the charge), and Angle (orientation of the loaded 

element to the charge based on the angle between the element normal vector and the vector to 

the charge location).  

Scalar Range and Legend 

The scalar data can be plotted based on the minimum and maximum data values (From Data) or 

based on user defined minimum and maximum values (User Defined).  The model contours and 

legend will be updated accordingly after making updates. 

The legend below the 3D Model defaults to five ticks or intervals.  Change the number in the 

Legend Ticks field to alter the unit division for the legend.  The units in the legend are determined 

by the scalar variable selected. 

2.4.4. REPORT 

The report section provides inputs for generating a report for the analyzed model.  The user must 

provide a Title and Footer for the report as well as select the 3D plots to include in the report.  

Author information can also be provided.  If a Logo is selected, it will be placed on the cover of 

the report.  A summary file can be selected in MS Word *.docx format and will be added at the 

beginning of the report.  The user may also provide discussion and conclusions by checking each 

option and clicking the input field to enter plain text into the resulting form.  The discussion and 

conclusions will be inserted at the end of the report.  Once all information is provided, the report 

can be generated by selecting Write Report from the File Menu or by pressing Ctrl+R. 

2.5. 3D VIEW AREA 

The 3D View Area provides a number of tools for interacting with the 3D model in a 3D View 

Toolbar, shown below.  A description of each tool and option follows. 

 
 
Basic Cursor  

 This is the basic cursor and does not interact directly with the 3D model.  However, 
regardless of which tool is selected, the view can be zoomed in and out with the scroll 

wheel on the mouse and the view can be panned by clicking and dragging with the right mouse 
button. 
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Zoom  
When this tool is selected, the user may click on the screen and drag down to zoom out or 
drag up to zoom in.  The mouse scroll wheel may also be used to zoom in (scroll up) or out 

(scroll down). 
 
Pan  

When this tool is selected, clicking and dragging with the left mouse button will pan the 
model on the screen relative to the movement of the mouse.  This operation may also be 

performed at any time or regardless of the tool selected by using the right mouse button. 
 
Rotate  

When the rotate tool is selected, clicking and dragging with the left mouse will freely 
rotate the model in any direction.  Dragging up and down will rotate about the current 

vertical axis.  Dragging right and left will rotate about the current horizontal axis. 
 
Rotate about X 

When this tool is selected, clicking and dragging up and down will rotate the model about 
the X-axis. 

 
Rotate about Y 

When this tool is selected, clicking and dragging left or right will rotate the model about 
the Y-axis. 

 
Rotate about Z 

When this tool is selected, clicking and dragging left or right will rotate the model about 
the Z-axis. 

 
View XY Plane 

Clicking this button will orient the model to be viewed in the X-Y plane. 
 

View YZ Plane 
Clicking this button will orient the model to be viewed in the Y-Z plane. 
 

View ZX Plane 
Clicking this button will orient the model to be viewed in the Z-X plane. 
 

Diametric View 
Clicking this button will orient the model in a diametric view, with the Z-axis up and split 
evenly between the X and Y-axis. 

 
Reset View 

Clicking this button will reset the view to the default orientation (Y-Z plane) and zoom level. 
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Run Analysis 
Clicking this button will run the analysis based on the current geometry and charge 
settings. 

 
Query Results 

Clicking on the model with this 
tool selected will display a table 

of the scalar values from the model.  
The four nodes of the element selected 
on the 3D model will be highlighted in 
blue in the table. 
 
Choose Background Color 

Clicking this button will allow the user to select a background color for the 3D View Area.  
The default color is black. 

 
Copy 3D View to Clipboard 

Clicking this button will copy the current 3D View as a bitmap image to the Windows 
Clipboard.   

 


